No, not the old one. Something between the hardware and my ears is borked, so I went out and bought a wireless Logitech h800.

Here's some of the grief I went through with the old one:

I have an ASUS Z87 Pro motherboard with a 4770K CPU running it. It's very nice. That motherboard comes with onboard sound, and the Fractal case supported front and rear analog jacks.

What happened:

The microphone stopped working after Windows 8.1 Update was applied (it figures).

Steps I've Taken with the 'old' headset:

- Testing my microphone on another computer. It worked.
- Plugged into both the front and rear audio jacks.
- Ensured the microphone enable switch was in the correct position.
- Configured AC97 as well HDAudio options in the BIOS and changed the setting in RealTek software.
- All sorts of combinations of software switches.
- Uninstalled the Realtek drivers and tried just using Microsoft drivers.
- Downloaded/re-installed the latest Realtek drivers.
- Yet more combinations of software switches.
- Downloaded and flashed the BIOS.
- Only looked briefly to see if there was another task interfering with the microphone. Nothing stood out.
- Tried various settings in Teamspeak.
- Tried various settings in the MS Control panel.

That was about 8 hours down the tubes and all to no avail.

Bought/plugged in a USB headset (not analog) and I was off to the races.